Question Same problem resolving host name vBOptimise CDN: AWS S3

Status
Not open for further replies.

pcam

Customer
#1
I'm having the same issue as rtiindia did in the thread setting up CDN with amazon s3

I have simply entered my standard region bucket name as well as a static website endpoint in the form http://BUCKET.s3-website-us-east-1.amazonaws.com. The former just shows @rtindia 's problem of hostname unable to resolve, while the latter complains of access permissions.

Is there an instruction manual? I have been wondering if in the file dbtech/vboptimise_pro/includes/cdn/amazon_s3/cdn.php

PHP:
        public function get_url()
        {
                return 'http://' . $this->cdn_settings['bucket'] . '.s3.amazonaws.com';
        }
is needing a region definition, although I saw that S3 buckets are essentially region-free. My url endpoint includes s3-website-us-east.

I did a "host" on my non-region specific bucket.s3.amazonaws.com with the result retrieved:

bucket.s3.amazonaws.com is an alias for s3-directional-w.amazonaws.com.
s3-directional-w.amazonaws.com is an alias for s3-1-w.amazonaws.com.
s3-1-w.amazonaws.com has address 52.xxx.xxx.xxx

Also, I am using the root Access Key ID / Secret Key pair of the aws account, where the S3 bucket has Read, Write for both Object access and Permissions access. I don't see any permission complaints from vBOptimise when using simply the bucket name, as it tries to upload synced settings and later fails, where as I have seen permission errors come up when attempting to perform a best security practice by delegating the S3 bucket to an IAM user.
 
Last edited:

Fillip H.

Staff member
Owner
Developer
#2
I'm honestly not sure how to deal with this - do they not offer a specific URL you should use to upload to your bucket in their control panel?

If they do, have you tried replacing the return value of get_url with that value?
 

pcam

Customer
#3
I was hoping for the resolution for the person who I mentioned so that learning how it worked for him might work for me. I don't understand why vBOptimise can authenticate and locate the bucket since the alternative attempt of using a www dns based endpoint showed me I was not the owner and that learning the presumably correct bucket name only brings me to my problem which is that during each attempt to push to the AWS, a repeated and per item error saying

Code:
Couldn't resolve host [mybucketname]
The screenshot rtiindia had in the thread setting up CDN with amazon s3 is the same thing that I'm stuck on.
 

DragonByte Technologies

Company Information
Staff member
Company Info
#5
Hello pcam,

This ticket has now been closed with the status Answered.

We hope your issue or question has been addressed to your satisfaction. If not, please feel free to re-open it by clicking this link.

If you have any further issues or questions, please feel free to start a new support ticket via the button at the top of every page.

Thank you!
 
Status
Not open for further replies.

vB Optimise

vBulletin 3.8.x vBulletin 4.x.x
Seller
DragonByte Technologies
Release date
Last update
Total downloads
1,889
Customer rating
0.00 star(s) 0 ratings
Top