Bug Issue when trying to save changes on "Misc Settings" Page - Xcache Authentication

Not open for further replies.
Product version
Forum version
vBulletin 4.2.x
Issue when trying to save changes on "Misc Settings" Page - Xcache Authentication

I had trouble getting settings to save on the "Misc Settings" page with Xcache Authentication already enabled.

I run Xcache with authentication enabled and when trying to save any settings (did not appear to be specifically related to the Xcache Authentication setting, but trying to save any setting change) on this page it would pop-up the Xcache authentication box to input username and password. I had already edited the config.php with this info but hadn't been able to change "Xcache Authentication" setting to yes on the Misc Settings page due to the box popping up and not liking anything I input. I was also getting Flush Cache errors on the System Test, presumable for the same reason.

My workaround was to turn off Xcache authentication in php.ini, restarted apache, saved settings on the "Misc Settings" page - this time with no issues. I then turned authentication back on in php.ini, restarted apache and then ran System Test again without errors.


Staff member
Have you edited /dbtech/vboptimise/config.php with your XCache username & password? The password in that config file needs to be in cleartext, not md5 format.
Yes, that was the first thing I did after install. It was acting as if it wasn't even looking for the config.php file since the "Xcache Authentication" option hadn't been saved to yes yet on that page. Oddly the authentication box would pop-up for on any attempted settings change save on the Misc Settings page (but not on any of the other settings pages).
Last edited:
Not open for further replies.

vB Optimise

vBulletin 3.8.x vBulletin 4.x.x
DragonByte Technologies
Release date
Last update
Total downloads
Customer rating
0.00 star(s) 0 ratings