Question Shoutbox stuck on loading, no input bar, options not saved

Glaude

New member
Hi,

Not looking for a full on support experience as I know how much of a pain mods have been on Vbulletin 5 (and I fully despise this situation caused by Vbulletin owners)
But just looking for a bit of help or insight.

I recently moved my forum to a new host, after the move, the shoutbox was working perfectly fine. In an attempt to debug the page where the shoutbox is loaded, the plugin was disabled momentarily, shortly after the plugin was enabled again, but nothing worked anymore (the shoutbox wasn't even displayed).

Now after going through a "new" install procedure (aka doing nothing but just going into products > import and point out the xml file) the shoutbox was able to display but there's no more input bar to post a shout, the main chat room is stuck on "Loading ...".

If I switch tabs and go back to the main shoutroom, I'm able to see the previous shouts

In the admin, it seems that no changes are saved (tried to add a description to the chat room for example, got a success message, but upon refresh, nothing was saved)

The php max input vars is required by the system to be increased, I can do that, but do note that this did not prevent the shoutbox from working before the disabling.

I have no errors in the Developer Console either

I haven't tried a full uninstall / reinstall yet because I don't know what the uninstall does exactly (does it wipe out all data from the shoutbox and all the uploaded files ?)

Thanks for any help that could be provided
 

Glaude

New member
Thanks a lot for the quick answer :)

Any log in particular would be of interest ?

We are running Nginx + mariaDb on a CentOs 8 server
 

Fillip H.

Staff member
Owner
Developer
I'm not familiar with Nginx so I could not tell you where Nginx logs PHP errors, sorry.
 

Glaude

New member
Thanks for your answer again.

I had a look through my php-fpm error.log file, the nginx error.log file and there isn't any error related to the shoutbox in them
 

Fillip H.

Staff member
Owner
Developer
Can you make it accessible to guests and make the forum accessible while using an adblocker so I can see the issue in action?
 

Glaude

New member
Wanted to send you some credentials via private message, but it tells me that my content is most likely spam and won't let me.

I can't turn the adblocker off, but there's no invasive ads on the website so you can just whitelist the domain, even temporarily to see
 

Fillip H.

Staff member
Owner
Developer
You should be using the "Secure details" button in the quick reply editor to attach details as this is encrypted whereas PMs are not.
 

Glaude

New member
Missed that, thanks, I've added regular user credentials for you to look at it, there's no difference in display for regular user & admin on that situation by the way
 

Fillip H.

Staff member
Owner
Developer
The issue is likely caused by this block of code:
Code:
    <script>
    jQuery(function($) {
        $(window).on('load', function() {
            console.log('before_scroll');
            var A = $('.b-content-entry').find(".js-editor")
            var B = vBulletin.ckeditor.getEditorContent(A);
            vBulletin.ckeditor.toggleToolbar($("#" + B), 1);
            console.log('after_scroll');
        });
    });
    </script>
Please remove it from your templates then try again.
 

Glaude

New member
It can't be caused by that, this was already present before with the shoutbox working.
This is a plugin activating the advanced editor of Vbulletin by default, it just do not check on which page it need to activate it.

But I deactivated it anyway to see if that was maybe the source for some obscure reason (you never know) and the problem remained the same
 

Glaude

New member
No it doesn't change.
I've tried installing it on a different server with a fresh untouched version of Vbulletin 5 (same version as the main forum) and the installation worked but there the Shoutbox doesn't even display
 

Fillip H.

Staff member
Owner
Developer
In that case it's likely the fact that you're running vB 5.4, the latest version supported is 5.2.
 

Glaude

New member
But it worked before, the activating and deactivating of the plugin, I don't really understand what this does
What would happen if I were to uninstall and reinstall, is all parameters, logs, history erased with that procedure ?
 

Glaude

New member
What does deactivating & reactivating do, if you know ? Does it changes anything in the templates or in the database ?
 

DragonByte Technologies

Company Information
Staff member
Company Info
Hello @Glaude,

We hope your ticket regarding vBShout has been addressed to your satisfaction. This ticket has now been scheduled to be closed.

If your ticket has not been resolved, you can reply to this thread at any point in the next 7 days in order to reopen the ticket, afterwards this thread will be closed.

Please do not reply to this thread if your ticket has been resolved.

Thank you.


- DragonByte Technologies, Ltd.
 

Beta vBShout

vBulletin 5.0.x vBulletin 5.1.x vBulletin 5.2.x
Seller
DragonByte Technologies
Release date
Last update
Total downloads
247
Customer rating
0.00 star(s) 0 ratings
Top