Question Permissions error when testing digest newsletter and 2 other questions

furnival

Customer
Hello, When I go to admincp> Dragonbyte Mail > Manage digests > test digest and click "test" I get a "You do not have permission to access this page" error. I get this while logged in as the administrator. How can I overcome this?

I have a couple more questions if I may:
Is there a way to change the email which the digest is sent from or is it the forum default for the webmaster's email?

I paid for a Branding Free License but the branding is there at the bottom of my forum home page. How can I get rid of this please?

Thank you for your time.
 

Fillip H.

Staff member
Owner
Developer
How can I overcome this?
Are you logged in to the front-end?

Is there a way to change the email which the digest is sent from or is it the forum default for the webmaster's email?
Sorry, there is not.

I paid for a Branding Free License but the branding is there at the bottom of my forum home page. How can I get rid of this please?
The branding free license was not assigned to your vBMail license. Please re-download the product and re-upload the files.
 

furnival

Customer
Are you logged in to the front-end?
Yes and the page with the permission denied error uses the front end template. So I am logged in to the front and back ends with the admin account. Any ideas?

On edit: I cannot access forum/vbmail.php through the front end @Fillip H. I mean I get the permission denied error.
 
Last edited:

furnival

Customer
URGENT:

I now get this error when logging in to admincp and, worse, my users get this error too when posting.

Code:
Class 'DBTech_Mail_Application_Core' not found on line 2 in public/forum/library/DBTech/Mail/vBulletin/hooks/userdata_postsave.php
#0 public/forum/includes/class_dm_user.php(2006) : eval()'d code(130): require()
#1 public/forum/includes/class_dm_user.php(2006): eval()
#2 public/forum/includes/class_dm_user.php(1741): vB_DataManager_User->post_save_each(true)
#3 public/forum/vbsso/includes/functions_communication.php(274): vB_DataManager_User->save()
#4 public/forum/vbsso/vbsso.php(187): vbsso_communication_dispatch_login_authentication_event()
#5 public/forum/includes/functions_login.php(412) : eval()'d code(2): vbsso_login_redirect_hook()
#6 public/forum/includes/functions_login.php(412): eval()
#7 public/forum/login.php(175): do_login_redirect()
#8 public/forum/dbseo.php(539): require('/srv/users/serv...')
#9 {main}
@Fillip H. can you help please?
 

furnival

Customer
Maybe I should go back to using the simpler DB Tech Newsletter mod? This mailing mod doesn't have any extra functionality I need anyway.
 

Fillip H.

Staff member
Owner
Developer
URGENT:

I now get this error when logging in to admincp and, worse, my users get this error too when posting.

Code:
Class 'DBTech_Mail_Application_Core' not found on line 2 in public/forum/library/DBTech/Mail/vBulletin/hooks/userdata_postsave.php
#0 public/forum/includes/class_dm_user.php(2006) : eval()'d code(130): require()
#1 public/forum/includes/class_dm_user.php(2006): eval()
#2 public/forum/includes/class_dm_user.php(1741): vB_DataManager_User->post_save_each(true)
#3 public/forum/vbsso/includes/functions_communication.php(274): vB_DataManager_User->save()
#4 public/forum/vbsso/vbsso.php(187): vbsso_communication_dispatch_login_authentication_event()
#5 public/forum/includes/functions_login.php(412) : eval()'d code(2): vbsso_login_redirect_hook()
#6 public/forum/includes/functions_login.php(412): eval()
#7 public/forum/login.php(175): do_login_redirect()
#8 public/forum/dbseo.php(539): require('/srv/users/serv...')
#9 {main}
@Fillip H. can you help please?
This is your server’s cache again, remember?
 

furnival

Customer
I still get the permissions error when I try to access forum/vbmail.php but that's fine I will just send out the digest without testing it. Hopefully the scheduled task will work without permission problems.
 

Fillip H.

Staff member
Owner
Developer
I wish I could be of further assistance, but when you have three or four different caching layers preventing changes from taking effect, it's sadly impossible for me to assist you further.

I've downloaded a fresh copy of the files from your license list and I can confirm the branding no longer appears.
 

furnival

Customer
@Fillip H. Sorry but I still need some help on this. I am sending out the digest email but when they click to change the frequency of the mailings they receive they go to https://domain,com/forum/vbmail.php?do=newsletter&action=reduce-frequency&hash=878957894578940&userid=2676786&newsletterid=1
and they get a permission denied error.

How can I fix the permission denied error on vbmail.php ? I have not set up any mailing lists as I am only interested in the newsletter feature. Are there some extra steps I need to take, please?
 

Fillip H.

Staff member
Owner
Developer
Your forum's cache is still preventing me from accessing your AdminCP so I cannot look into this further. I would strongly recommend you ask your server administrator to completely replace your caching setup, as it's clearly not working right now.
 

furnival

Customer
Your forum's cache is still preventing me from accessing your AdminCP so I cannot look into this further. I would strongly recommend you ask your server administrator to completely replace your caching setup, as it's clearly not working right now.
But Fillip my caching setup is YOUR caching setup, i.e. VB Optimise (Pro)! I understand I have caused you frustration in the past couple of days with the opcode caching issue and Cloudflare but these have been turned off now.

Please help me fix this. My forum is almost unusable now! It looks like when I uploaded the VB Mail files I overwrote the changes you made and so now have the same errors as in post #5. So it should be possible to fix this via ftp, reapplying whatever changes you made last night. Please help!
 

furnival

Customer
I disabled all hooks via config.php, logged in to the admincp, flushed VBOptimise's cache and disabled VB Optimise and reactivated hooks.

but, in admincp, when I click VBMail > Maintenance I see this error:
Class 'DBTech_Mail_Application_Core' not found on line 48 in /public/forum/admincp/vbmail.php
#0 {main}

(VB Mail is currently deactivated)

I promise the caching problems are behind us now! :D
 

furnival

Customer
I still have issues and no-one has posted on my forum in the last 10 hours (there is normally a post every few minutes). This is quite serious for me, please help. Should I uninstall VB Mail? I have been getting reports that my users can't even log in!
 

vBMail

vBulletin 3.8.x vBulletin 4.x.x
Seller
DragonByte Technologies
Release date
Last update
Total downloads
719
Customer rating
0.00 star(s) 0 ratings
Top