Bug API Endpoint returning errors

Status
Not open for further replies.

karol_avast

Customer
After attempting to retrieve any form of API endpoints by eCommerce, it returns the following error:
JSON:
{
    "errors": [
        {
            "code": "requested_page_not_found",
            "message": "The requested page could not be found.",
            "params": []
        }
    ]
}
Example URL used: https://example.com/api/dbtech-ecommerce

Making a mistake in the URL returns a different error:
JSON:
{
    "errors": [
        {
            "code": "endpoint_not_found",
            "message": "Requested endpoint cannot be found.",
            "params": {
                "reason": "invalid_route"
            }
        }
    ]
}
URL used: https://example.com/api/dbtech-ecommerca

Retrieving any form of XenForo returns a valid output,
Am I doing something wrong or?
 

Fillip H.

Staff member
Owner
Developer
I don't know what else to say, it works perfectly fine on this site.

vGVml1H.png
 

Fillip H.

Staff member
Owner
Developer
Only if the purchase has inputs (such as Branding Free here @ DBTech). I don't believe there's an option for a "Welcome Thread" for the user who made the purchase at this time, sorry.
 

DragonByte Technologies

Company Information
Staff member
Company Info
Hello @karol_avast,

We hope your ticket regarding DragonByte eCommerce has been addressed to your satisfaction. This ticket has now been scheduled to be closed.

If your ticket has not been resolved, you can reply to this thread at any point in the next 7 days in order to reopen the ticket, afterwards this thread will be closed.

Please do not reply to this thread if your ticket has been resolved.

Thank you.


- DragonByte Technologies, Ltd.
 
Status
Not open for further replies.

DragonByte eCommerce

XenForo 2.0.6+ XenForo 2.1.x XenForo 2.2.x
Seller
DragonByte Technologies
Release date
Last update
Total downloads
1,653
Customer rating
4.83 star(s) 6 ratings
Top