Bug When installed, site asks for login information over cookies consent, can't use site

Status
Not open for further replies.
Website
http://slobodni.net
Product version
1.0.0pl1
Forum version
vBulletin 4.1.x
#1
I installed mod first on my test site, there was everything ok (it is the same server).

After that, when everything worked out, I tried to install it on my main site. Well, problem is that I see this message:

Authentication required.
Slobodni.net za slobodni svijet requires username and password
Your connection to this site is not private.

I don't know what username and password to use, also after I dismiss message I can't accept cookies.

I can disable mod with settings, after that things work fine, but I can't use your mod if it asks for some unknown password.

I'm in process of transferring to https protocol, so some things do redirect to https, some still not. I used (and it is still on, but I tried to turn it off also) script which doesn't allow using https protocol, that's why I tried to use your mod.
 
#2
In see this error:

HTML:
GET http://slobodni.net/packages/DBTech/CookieControl/JS/core.js?v=100pl1 
(index):16192 GET http://slobodni.net/packages/DBTech/CookieControl/JS/3rdparty/Cookie/js.cookie-2.0.3.min.js 401 (Unauthorized)
Like something is blocking my access to this script.
 
#3
OK, I then checked server settings, packages is password protected directory, this is something I read on vBulletin security, that this directory needs to be protected. That's the reason why password was asked. Now I solved this, but I have second problem:

When mod is enabled, even when I accept cookies, page stops with loading scripts for a long time. About ten or maybe a bit more seconds. Even when I accept cookies site doesn't load scripts for some time. After this time passes, scripts are loaded.

I guess I don't need to tell you, this is slowing site considerably. This even affect cookie consent script, you can't do anything till js is loaded and you have to wait for ten seconds or more. Strange.
 
#4
I restarted server, that solved problem with waiting for loading js. Guess that this was something server related that restart solved.

At the moment I don't have problems, but this story may help someone...

Just to ask, why do you use packages directory, before you used DBTech's own directory? Maybe it would be better to use this directory for this mod also?
 

DragonByte Technologies

Company Information
Staff member
Company Info
#5
Hello Alan_SP,

This ticket has now been closed with the status Not A Bug.

We hope your issue or question has been addressed to your satisfaction. If not, please feel free to re-open it by clicking this link.

If you have any further issues or questions, please feel free to start a new support ticket via the button at the top of every page.

Thank you!
 
Status
Not open for further replies.

Cookie Control

vBulletin 4.x.x
Seller
DragonByte Technologies
Release date
Last update
Total downloads
39
Customer rating
0.00 star(s) 0 ratings
Top