Bug Lite version missing ipcheck files

Status
Not open for further replies.
Website
https://www.thebuddyforum.com
Product version
1.2.1
Forum version
vBulletin 4.2.x
#1
So we are trialing the new version of vbsecurity and it seems like you have replaced the built in ipsearch functionality of vbulletin with your own but then failed to include the doips.php

Heres the code that I looked at to see why we were getting the error and the lite pkg does not include a doips.php

Code:
if (!file_exists(DIR . '/dbtech/vbsecurity/actions/admin/' . $action . '.php'))
{
	if (!file_exists(DIR . '/dbtech/[B]vbsecurity_pro[/B]/actions/admin/' . $action . '.php'))
	{
		// Throw error from invalid action
		print_cp_message($vbphrase['dbtech_vbsecurity_invalid_action']);
	}
	else
	{
		// Include the selected file
		include_once(DIR . '/dbtech/[B]vbsecurity_pro[/B]/actions/admin/' . $action . '.php');	
	}
}
else
{
	// Include the selected file
	include_once(DIR . '/dbtech/vbsecurity/actions/admin/' . $action . '.php');	
}

Summary:
Missing doips.php
 

Belazor

Staff member
Owner
Developer
Customer
#2
the included vbsecurity.php only checks for the exsitance of the pro directory which ofcourse does not exist cause this is the lite version.

Code:
if (!file_exists(DIR . '/dbtech/vbsecurity/actions/admin/' . $action . '.php'))
{
	if (!file_exists(DIR . '/dbtech/[B]vbsecurity_pro[/B]/actions/admin/' . $action . '.php'))
	{
		// Throw error from invalid action
		print_cp_message($vbphrase['dbtech_vbsecurity_invalid_action']);
	}
	else
	{
		// Include the selected file
		include_once(DIR . '/dbtech/[B]vbsecurity_pro[/B]/actions/admin/' . $action . '.php');	
	}
}
else
{
	// Include the selected file
	include_once(DIR . '/dbtech/vbsecurity/actions/admin/' . $action . '.php');	
}
Here you can see that this if/else statement is incorrect as it checks for _pro and if it doesnt exist it still trys to include it.
Sorry, but this is an incorrect assessment. As you can see by the first statement, it checks to see if the file exists in the Lite directory. If not, it checks for it in the Pro directory. If not, it throws an error saying the action cannot be found.

If the first if check ("does this file NOT exist in the Lite dir?") fails, the Lite file is included.
If the second if check ("does this file NOT exist in the Pro dir?") does NOT fail, the Pro file is included.

Does that make more sense? :)

I'll correct the incorrect doips.php override in v2.0, this is intended to be a Pro-only feature.
 
#3
Sorry, but this is an incorrect assessment. As you can see by the first statement, it checks to see if the file exists in the Lite directory. If not, it checks for it in the Pro directory. If not, it throws an error saying the action cannot be found.

If the first if check ("does this file NOT exist in the Lite dir?") fails, the Lite file is included.
If the second if check ("does this file NOT exist in the Pro dir?") does NOT fail, the Pro file is included.

Does that make more sense? :)

I'll correct the incorrect doips.php override in v2.0, this is intended to be a Pro-only feature.

Is there an eta on this as now my admins cannot search by ips.
 

Belazor

Staff member
Owner
Developer
Customer
#4
v2.0 will be released tonight, approx. 8 hours from the time of writing this post. Sorry for the inconvenience :(
 

Belazor

Staff member
Owner
Developer
Customer
#5
Hello Bossland,

This ticket has now been closed with the status Fixed.

We hope your issue or question has been addressed to your satisfaction. If not, please feel free to re-open it by clicking this link.

If you have any further issues or questions, please feel free to start a new support ticket via the button at the top of every page.

Thank you!
 
Status
Not open for further replies.

vBSecurity

vBulletin 3.8.x vBulletin 4.x.x
Seller
DragonByte Technologies
Release date
Last update
Total downloads
743
Customer rating
0.00 star(s) 0 ratings
Top