Gallery plugin - I migrate a large PhotoPost Pro user base?

Status
Not open for further replies.
#1
Gallery plugin - Can I migrate a large PhotoPost Pro user base?

I have three vB3.8 forums, each with a fairly large PhotoPost Pro gallery. As PPPro is no longer supported I would like to migrate our users and their photos to the DragonByte gallery plugin if this is suitable. We're currently stuck on PHP 5.5 because of PPPro. The overall aim is to update to PHP 5.6 or even higher, including a move from vB3.8 to vB4 and possibly 5.

Thanks,

Ian
 
Last edited:

Belazor

Staff member
Owner
Developer
Customer
#2
Hi there,

Two things to note:
1. Our gallery mod does not work on vBulletin 3.x, only 4.x.
2. We do not have a vB5 version, nor do we have any plans to bring the mod to vB5 - I would strongly recommend avoiding vB5 at all costs if you plan to run custom modifications on your site.

Regarding PHP 5.5, as it is unsupported by The PHP Group it is also strongly recommended to not run such an old version, and we don't officially support it, although I don't see a reason why it won't work. All our mods are compatible with PHP 7.0 and 7.1 as well, which are the currently active and supported PHP versions over @ php.net.

In short, you would first need to upgrade to vB 4.2.5, then import PP Pro into our Gallery mod. We recently released an update that vastly improves the importing process, so I see no reason why the mod would not be suitable as a PP Pro replacement.

Feel free to let me know if you have any further questions!
 
#3
Hi there,

Two things to note:
1. Our gallery mod does not work on vBulletin 3.x, only 4.x.
2. We do not have a vB5 version, nor do we have any plans to bring the mod to vB5 - I would strongly recommend avoiding vB5 at all costs if you plan to run custom modifications on your site.

Regarding PHP 5.5, as it is unsupported by The PHP Group it is also strongly recommended to not run such an old version, and we don't officially support it, although I don't see a reason why it won't work. All our mods are compatible with PHP 7.0 and 7.1 as well, which are the currently active and supported PHP versions over @ php.net.

In short, you would first need to upgrade to vB 4.2.5, then import PP Pro into our Gallery mod. We recently released an update that vastly improves the importing process, so I see no reason why the mod would not be suitable as a PP Pro replacement.

Feel free to let me know if you have any further questions!
Yes, I'm aware that I am in a catch-22 situation and I have warned my users that there will be disruption while we update things.

Updating to vB4 is fine and I am more inclined to do this rather than 5.

Ian
 
#4
One other question - as our users have extensively used PPPro for hosting images posted to the forum, I am hoping that the location of these images can remain unchanged after the migration, even if that means keeping a legacy duplicate of all the images up to the point of migration.

Ian

PS Does PPPro have to be functional for the migration to work or does the import only require the database tables?
 
Last edited:

Belazor

Staff member
Owner
Developer
Customer
#5
Unfortunately there's no way to keep the existing PP structure, sorry :(

Any linked images (or inline attached images) will not function after the import.
 
#6
Can I maintain PPPro but not for new images and simply install the Gallery plugin for use from thereon so that I don't disrupt the forum's posted images?
 
#7
I've just paid for three lifetime installations of the Gallery - seeing as you had an incentive about to expire :)

The PayPal receipt doesn't appear to have a VAT number - can I obtain a VAT invoice?
 

Belazor

Staff member
Owner
Developer
Customer
#8
Can I maintain PPPro but not for new images and simply install the Gallery plugin for use from thereon so that I don't disrupt the forum's posted images?
I don't see why not :)

I've just paid for three lifetime installations of the Gallery - seeing as you had an incentive about to expire :)

The PayPal receipt doesn't appear to have a VAT number - can I obtain a VAT invoice?
Once we can verify your VAT number you will be able to download a VAT invoice from your Client Area. The VIES validation service is down, so your entered VAT number cannot be verified at the time of writing this.
 
#10
Looks like I have the VAT invoice thanks.

Can I just verify, if I import users from our PPPro gallery then that alters PPPro, or does this only happen if you import images as well?

I am trying to understand the info that importing from PPPro means "Any linked images (or inline attached images) will not function after the import."

Hopefully that simply means that there is an assumption that PPPro will be removed (manually) after the import has completed.

It now seems that my aim is to continue running PPPro simply to maintain visibility of existing images in the forum that are hosted on PPPro. So it would be disabled for new image uploads.

Ian
 
Last edited:

Belazor

Staff member
Owner
Developer
Customer
#11
I'm not sure I fully understand the question, but my previous answer was given assuming you would uninstall/remove PP Pro after importing into our mod.

If you leave PP Pro installed, then existing linked images will continue to function, although you would be locked out of critical PHP security patches by being stuck on an old unsupported version of PHP. This could lead to your site being targeted by malicious individuals (not to mention the performance benefits from using PHP 5.6 or newer), so it is strongly recommended that you do not do this.

Our importer does not alter or remove PP Pro.
 
#12
Thanks for the clarification.

I am very aware of the problem with PHP 5.5 - which is what we are on. I think the very latest version of PPPro is compatible with later versions of PHP.

if we can move to 5.6 along with an upgrade to vBulletin 4 that would be good enough for now.
 
#13
I see that vB4 can be installed with PHP 5.5.

My aim is to migrate to PHP 5.6 from 5.5 as soon as possible but if I can move from vB3 to 4 before moving to PHP 5.6 that could be useful assuming I can install your gallery code with PHP 5.5 as well. The PHP 5.5-5.6 move would then follow. Would this be possible?

I have discovered that there is a vB3 version that can run in PHP 5.6 but I would prefer to install VB4 and customise it before going to PHP 5.6.

I'm no expert so if anyone thinks my preference is really stupid - I respect that and am eager to understand why.
 
#14
One other question, I like the feature that can resize images uploaded so there is no need to do that before uploading but if, say, I set a maximum limit of 1600 pixels, for example, and the system resizes an image accordingly, can (or does it anyway) the originally uploaded over-large image be discarded or must it remain on the server? Another way of looking at it, is the resizing from the original size done on the fly?

With original camera files now even tens of megabytes, even though I have a generous disk capacity on the server, it could be quickly gobbled up by large original files, which I'd rather avoid.
 

DragonByte Technologies

Company Information
Staff member
Company Info
#18
Hello IanB,

This ticket has now been closed with the status Answered.

We hope your issue or question has been addressed to your satisfaction. If not, please feel free to re-open it by clicking this link.

If you have any further issues or questions, please feel free to start a new support ticket via the button at the top of every page.

Thank you!
 
Status
Not open for further replies.
Top