DragonByte Tech | vBulletin Mods & Addons - Powered by vBulletin





User Tag List

Likes Likes:  0
Dislikes Dislikes:  0
Page 2 of 3 First 123 Last
Results 11 to 20 of 27

Thread: Reset newsletter to start scanning again from user #1


Forum: DragonByte Newsletter Professional Support

Questions & Answers for DragonByte Newsletter.

  1. #11
    Member
    Level 0 (1,000 Loyalty Points)

    User InfoThanks / Tagging InfoGifts / Achievements / AwardsActivity Stats
    Join Date
    Jun 2010
    Posts
    62
    Rep Power
    8

    Default

    Okay. Thank you for your prompt replies.
    0 0 0
     
    Reset newsletter to start scanning again from user #1 Send PM  

  2. #12
    Bot Poster
    Level 0 (0 Loyalty Points)

    User InfoThanks / Tagging InfoGifts / Achievements / AwardsActivity Stats
    Join Date
    Dec 2010
    Posts
    1,361
    Rep Power
    0

    Default

    Hello @djbaxter,

    This ticket has now been closed with the status Answered.

    We hope your issue or question has been addressed to your satisfaction. If not, please feel free to re-open it by clicking this link.

    If you have any further issues or questions, please feel free to start a new support ticket via the button at the top of every page.

    Thank you!
    0 0 0
     
    Reset newsletter to start scanning again from user #1 Send PM  

  3. #13
    Member
    Level 0 (1,000 Loyalty Points)

    User InfoThanks / Tagging InfoGifts / Achievements / AwardsActivity Stats
    Join Date
    Jun 2010
    Posts
    62
    Rep Power
    8

    Default

    I have tried the SQL query you gave me several times. The query seems to run successfully.

    However, after turning off the scheduled task and re-starting it, or disabling the newsletter add-on entirely and then re-enabling it, it is taking an unusually long time to send out the newsletter on one forum.

    At Local Search Forum (owned by Linda Buquet who purchased a license here under her own name), I am the technical admin there. I am user #1 and Linda is user #2 on that forum.

    I enabled the newsletter add-on last Sunday night after stopping it and running the SQL query. I would expect that I would have received my copy of the newsletter no later than the next morning. In fact, it did not arrive until yesterday (Friday April 29) late evening. Linda is reporting the same experience.

    We have now tried this three times. We have double checked the vBulletin email settings as well as her server settings (VPS). There are no mail throttles in place.

    This is a forum with 3,039 mostly active members, i.e., very active Monday through Friday and somewhat slower on the weekends. There are even more non-logged in daily visitors. Thus, there is no reason to suspect that the scheduled task would not be fired by the vBulletin pixel.

    I am baffled. The newsletter should obviously not take almost 6 full days to reach me, user #1, after running the reset SQL query.

    Any advice or ideas?
    0 0 0
     
    Reset newsletter to start scanning again from user #1 Send PM  

  4. #14
    Founder
    Level 0 (0 Loyalty Points)
    Belazor's Avatar
    User InfoThanks / Tagging InfoGifts / Achievements / AwardsActivity Stats
    Join Date
    Dec 2009
    Location
    Glasgow, United Kingdom
    Age
    30
    Posts
    27,735
    Blog Entries
    13
    Rep Power
    10

    Default

    Hmm, I think we need to enable more detailed logging in order to get to the bottom of this. I've made appropriate changes and re-uploaded v1.1.1 to the Client Area.

    Could you re-download, re-upload, then re-run the queries?

    The reason why this is so weird is that this is the exact query used when fetching users:
    Code:
    SELECT * FROM user
    WHERE dbtech_newsletter_receive = 1
    	AND dbtech_newsletter_lastreceive <= (1461974400 - (dbtech_newsletter_frequency * 604800))
    ORDER BY userid ASC
    LIMIT 250
    That's for midnight tonight. The order in which the results appear determines the order in which people receive their newsletters. What the "lastreceive" line means is; "include users who have not received the newsletter for X weeks, where X is their chosen frequency setting".

    So if you set dbtech_newsletter_receive to 1 and dbtech_newsletter_lastreceive to 0 for your user, then it will tell the mod this user has never received the newsletter. Once they receive it, it'll take at least 1 week before they receive it again.

    Hope this helps.
    Fillip Hannisdal
    Founder & Programming Director
    DragonByte Technologies http://www.DragonByte-Tech.com


    Please do not Private Message me with support requests or product questions. PMs are only for exchanging sensitive information (like FTP / AdminCP logins).
    Please do not Private Message me with business related queries (refunds, complaints, feedback, etc). Decado is the person to PM for those issues.
    Please do not Private Message Decado with support requests or forum errors.

    When I say "Hotfix Released" it means you should re-download the product and re-upload the files.
    Like our products? Want to be notified on social media networks when we release updates or new products? Click the buttons below to Like us on Facebook, Follow us on Twitter and Follow us on Google+!
    0 0 0
     
    Reset newsletter to start scanning again from user #1 Send PM  

  5. #15
    Member
    Level 0 (1,000 Loyalty Points)

    User InfoThanks / Tagging InfoGifts / Achievements / AwardsActivity Stats
    Join Date
    Jun 2010
    Posts
    62
    Rep Power
    8

    Default

    Sorry for the delay in getting back to you... got bogged down in a few other projects.

    I have now uploaded the new version of 1.1.1 to one of the forums for testing.

    I just re-ran the query

    Code:
    UPDATE user SET dbtech_newsletter_lastreceive = 0
    Where do I look for the new "debugging" information?

    All of the forums using the Pro version are now showing signs of "slippage", with the newsletter showing up on days that gradually slide toward the weekend and then into the next week.

    I'm wondering about increasing the number of newsletters sent out at a time and/or decreasing the intervals between sending. These are dedicated servers and can handle the load but we need more predictability on when the newsletters will be delivered. Having them show up on a Friday night or weekend for a business forum isn't acceptable.
    Last edited by djbaxter; 27th May 2016 at 21:52.
    0 0 0
     
    Reset newsletter to start scanning again from user #1 Send PM  

  6. #16
    Member
    Level 0 (1,000 Loyalty Points)

    User InfoThanks / Tagging InfoGifts / Achievements / AwardsActivity Stats
    Join Date
    Jun 2010
    Posts
    62
    Rep Power
    8

    Default

    I have been running the query via the AdminCP <strong>Execute SQL Query</strong> option<strong></strong> up to now:

    Code:
    UPDATE user SET dbtech_newsletter_lastreceive = 0
    However, I just tried running it via phpMyAdmin and I get this error:

    Code:
    #1054 - Unknown column 'dbtech_newsletter_lastreceive' in 'field list'
    This is with the latest version of 1.1.1 with debugging.

    ????

    This is on a forum using your debug version.

    I just tried the same query on another forum using Newsletter Pro 1.1.1, the version prior to your debug version, and I don't get that error.

    Any suggestions?
    Last edited by djbaxter; 27th May 2016 at 22:10.
    0 0 0
     
    Reset newsletter to start scanning again from user #1 Send PM  

  7. #17
    Founder
    Level 0 (0 Loyalty Points)
    Belazor's Avatar
    User InfoThanks / Tagging InfoGifts / Achievements / AwardsActivity Stats
    Join Date
    Dec 2009
    Location
    Glasgow, United Kingdom
    Age
    30
    Posts
    27,735
    Blog Entries
    13
    Rep Power
    10

    Default

    Quote Originally Posted by djbaxter View Post
    All of the forums using the Pro version are now showing signs of "slippage", with the newsletter showing up on days that gradually slide toward the weekend and then into the next week.
    Can you check your vBulletin Options under Email Options that the "mail per scheduled task run" is set to a respectable amount (default is 10 I believe, I recommend 250)?

    This is the most common reason for this. You can check if this is the case by checking if the mailqueue table is full.

    Quote Originally Posted by djbaxter View Post
    Any suggestions?
    Did you remember to include your table prefix?
    Fillip Hannisdal
    Founder & Programming Director
    DragonByte Technologies http://www.DragonByte-Tech.com


    Please do not Private Message me with support requests or product questions. PMs are only for exchanging sensitive information (like FTP / AdminCP logins).
    Please do not Private Message me with business related queries (refunds, complaints, feedback, etc). Decado is the person to PM for those issues.
    Please do not Private Message Decado with support requests or forum errors.

    When I say "Hotfix Released" it means you should re-download the product and re-upload the files.
    Like our products? Want to be notified on social media networks when we release updates or new products? Click the buttons below to Like us on Facebook, Follow us on Twitter and Follow us on Google+!
    0 0 0
     
    Reset newsletter to start scanning again from user #1 Send PM  

  8. #18
    Member
    Level 0 (1,000 Loyalty Points)

    User InfoThanks / Tagging InfoGifts / Achievements / AwardsActivity Stats
    Join Date
    Jun 2010
    Posts
    62
    Rep Power
    8

    Default

    Can you check your vBulletin Options under Email Options that the "mail per scheduled task run" is set to a respectable amount (default is 10 I believe, I recommend 250)?

    This is the most common reason for this. You can check if this is the case by checking if the mailqueue table is full.
    We haven't been using the mailqueue system but the number per batch was set at 500.

    There are no emails in the queue.

    Did you remember to include your table prefix?
    Yes, for that forum there is no prefix. And after installing your debug version I don't think it's running at all because the table doesn't exist.
    0 0 0
     
    Reset newsletter to start scanning again from user #1 Send PM  

  9. #19
    Member
    Level 0 (1,000 Loyalty Points)

    User InfoThanks / Tagging InfoGifts / Achievements / AwardsActivity Stats
    Join Date
    Jun 2010
    Posts
    62
    Rep Power
    8

    Default

    I manually re-added the three dbtech_ tables by comparing them with another forum with the non-debug version installed.

    I turned off the newsletter and the scheduled task temporarily.

    I then set up the forum in question to use the vBulletin email queue with 250 as the default.

    I will restart the newsletter next week and see how it goes...

    Can you please replace v 1.1.1 with the previous version? I'm not sure how it deleted the tables (I had it set to overwrite) but now I no longer have a copy of the non-debug 1.1.1 version.
    0 0 0
     
    Reset newsletter to start scanning again from user #1 Send PM  

  10. #20
    Founder
    Level 0 (0 Loyalty Points)
    Belazor's Avatar
    User InfoThanks / Tagging InfoGifts / Achievements / AwardsActivity Stats
    Join Date
    Dec 2009
    Location
    Glasgow, United Kingdom
    Age
    30
    Posts
    27,735
    Blog Entries
    13
    Rep Power
    10

    Default

    Nothing has changed in the updated v1.1.1 version other than adding more logging to the scheduled task. The installer has not changed in any way, shape or form.

    Could you try uninstalling it and re-installing it?
    Fillip Hannisdal
    Founder & Programming Director
    DragonByte Technologies http://www.DragonByte-Tech.com


    Please do not Private Message me with support requests or product questions. PMs are only for exchanging sensitive information (like FTP / AdminCP logins).
    Please do not Private Message me with business related queries (refunds, complaints, feedback, etc). Decado is the person to PM for those issues.
    Please do not Private Message Decado with support requests or forum errors.

    When I say "Hotfix Released" it means you should re-download the product and re-upload the files.
    Like our products? Want to be notified on social media networks when we release updates or new products? Click the buttons below to Like us on Facebook, Follow us on Twitter and Follow us on Google+!
    0 0 0
     
    Reset newsletter to start scanning again from user #1 Send PM  

Page 2 of 3 First 123 Last

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.