You might need to upgrade to vB 4.2.3 Beta 1 or newer, as it contains multiple fixes for PHP 5.4 and newer